Symptom
I am not able to connect to the API
Cause
- API access for users is not enabled in the control panel by default. This needs to be activated per user from the RCP (Reseller Control Panel).
- IP whitelist or blacklist is blocking the connection - causing error "Acces Denied"
Resolution
1: Log into RCP (Reseller Control Panel). Navigate to Account >> Account Overview or click the link (for Sandbox, click this link). Check whether "API access" is enabled (Green dot if enabled and Red if disabled).
2: If the API access is "Disabled" as shown in the screenshot above, click on the username
3: Click on "Edit"
4: Click on the checkbox "API access Enabled"
5: Click on "Update contact"
6: API Access is now enabled for this username!
7: Check if any IP whitelisting or blacklisting is entered.
Please remove the IP addresses until the connection with the API has been established successfully before adding the IP addresses.
More information about IP whitelisting and blacklisting can be read here.