Symptoms
Domain registrants (owners) don't get ICANN-required verification emails if Custom Contact verification branding has been set up.
Cause
The domain that is to be used (or rather to have the appearance of using) to send emails (that otherwise would come directly from Openprovider addresses) is not authenticated within our infrastructure:
Resolution
You will be prompted to perform this procedure from Contact verification branding page, however, if forgotten, please follow the instructions:
- Navigate to Account > Settings > E-mail authentication page in RCP
- Click on Add domain and add your domain which will be used as the E-mail sender in contact verification emails.