WHMCS Registrar TLD & Pricing Sync Utility doesn't work or blank page is shown when running the sync

Update: an alternative solution to the problem has been introduced in a separate branch of the project in the module's repository. Please check the details here to get more information on the matter.

Symptoms

  • TLD and Pricing synchronization utility doesn't produce any results upon running it
  • The cogwheel animation in WHMCS is followed by a blank page

Cause

Due to the number of TLDs supported by Openprovider, some WHMCS installations may have time-outs when synchronizing the TLD pricing. This happens because Openprovider API needs to calculate custom prices (depending on the membership) for one's particular account and WHMCS requires a significant amount of time to process all 1500+ TLDs.

Resolution

  1. Enable System Module Debug Log in WHMCS
  2. Increase max_execution_time and memory_limit for PHP scripts
  3. Start TLD Price sync
  4. If the page goes blank after the animation disappears, navigate to the System Module Debug Log, and make sure searchextensionrequest API request is being called.
  5. If it is, find whether or not the response is cut off abruptly.
  6. If point 5 is true, then the execution is most probably terminated by the timeout of the web server
  7. Try increasing the TimeOut directive in the config file of httpd service or its equivalent for nginx
  8. Restart the synchronization.
Was this article helpful?
Additional questions? Submit a request